Don't link everything against lib{z,bz2,pam,gdbm}.
[doldaconnect.git] / daemon / Makefile.am
index 342ad7a..3ff8bef 100644 (file)
@@ -9,22 +9,22 @@ doldacond_SOURCES=    main.c \
                        filenet.c \
                        filenet.h \
                        fnet-dc.c \
+                       fnet-adc.c \
                        auth.c \
                        auth.h \
                        auth-pam.c \
                        auth-krb5.c \
+                       auth-unix.c \
                        client.c \
                        client.h \
                        net.c \
                        net.h \
-                       utils.c \
-                       utils.h \
                        log.c \
-                       log.h \
                        ui.c \
                        conf.c \
-                       conf.h \
-                       tiger.c \
-                       tiger.h
+                       conf.h
+
 EXTRA_DIST=emacs-local
-doldacond_LDADD=@KRB5_LDADD@ -lbz2 -lz
+doldacond_LDADD=$(top_srcdir)/common/libcommon.a \
+               @KRB5_LIBS@ -lbz2 -lz -lgdbm @PAM_LIBS@
+doldacond_CPPFLAGS=-I$(top_srcdir)/include -DDAEMON @KRB5_CFLAGS@