Don't link everything against lib{z,bz2,pam,gdbm}.
[doldaconnect.git] / daemon / Makefile.am
index 306df3d..3ff8bef 100644 (file)
@@ -14,6 +14,7 @@ doldacond_SOURCES=    main.c \
                        auth.h \
                        auth-pam.c \
                        auth-krb5.c \
+                       auth-unix.c \
                        client.c \
                        client.h \
                        net.c \
@@ -23,8 +24,7 @@ doldacond_SOURCES=    main.c \
                        conf.c \
                        conf.h
 
-AM_CPPFLAGS=-I$(top_srcdir)/include -DDAEMON
-
 EXTRA_DIST=emacs-local
 doldacond_LDADD=$(top_srcdir)/common/libcommon.a \
-               @KRB5_LDADD@ -lbz2 -lz
+               @KRB5_LIBS@ -lbz2 -lz -lgdbm @PAM_LIBS@
+doldacond_CPPFLAGS=-I$(top_srcdir)/include -DDAEMON @KRB5_CFLAGS@