Make building the daemon optional
[doldaconnect.git] / daemon / Makefile.am
index e4f0ea2..1600b31 100644 (file)
@@ -1,4 +1,6 @@
+if DAEMON
 bin_PROGRAMS=doldacond
+endif
 doldacond_SOURCES=     main.c \
                        search.c \
                        search.h \
@@ -24,8 +26,7 @@ doldacond_SOURCES=    main.c \
                        conf.c \
                        conf.h
 
-AM_CPPFLAGS=-I$(top_srcdir)/include -DDAEMON
-
 EXTRA_DIST=emacs-local
 doldacond_LDADD=$(top_srcdir)/common/libcommon.a \
-               @KRB5_LDADD@ -lbz2 -lz
+               @KRB5_LIBS@ -lbz2 -lz -lgdbm @PAM_LIBS@
+doldacond_CPPFLAGS=-I$(top_srcdir)/include -DDAEMON @KRB5_CFLAGS@