Make building the daemon optional
[doldaconnect.git] / daemon / Makefile.am
index 9f97a47..1600b31 100644 (file)
@@ -1,4 +1,6 @@
+if DAEMON
 bin_PROGRAMS=doldacond
+endif
 doldacond_SOURCES=     main.c \
                        search.c \
                        search.h \
@@ -14,18 +16,17 @@ doldacond_SOURCES=  main.c \
                        auth.h \
                        auth-pam.c \
                        auth-krb5.c \
+                       auth-unix.c \
                        client.c \
                        client.h \
                        net.c \
                        net.h \
-                       utils.c \
-                       utils.h \
                        log.c \
-                       log.h \
                        ui.c \
                        conf.c \
-                       conf.h \
-                       tiger.c \
-                       tiger.h
+                       conf.h
+
 EXTRA_DIST=emacs-local
-doldacond_LDADD=@KRB5_LDADD@ -lbz2 -lz
+doldacond_LDADD=$(top_srcdir)/common/libcommon.a \
+               @KRB5_LIBS@ -lbz2 -lz -lgdbm @PAM_LIBS@
+doldacond_CPPFLAGS=-I$(top_srcdir)/include -DDAEMON @KRB5_CFLAGS@