Created a (hopefully) sane way to install desktop data.
[doldaconnect.git] / clients / gui-shell / Makefile.am
index 43e6afc..4400398 100644 (file)
@@ -1,13 +1,12 @@
 if GUISHELL
 bin_PROGRAMS=dolcon-launch doldacond-shell
-app_DATA=dolcon.desktop
 endif
 
 dolcon_launch_SOURCES=launch.c
 
 doldacond_shell_SOURCES=dsh.c
 
-EXTRA_DIST=dsh-start.desc dsh-menu.desc dolcon.desktop
+EXTRA_DIST=dsh-start.desc dsh-menu.desc
 BUILT_SOURCES=dsh-start.gtk dsh-menu.gtk
 
 dsh.c: dsh-start.gtk dsh-menu.gtk
@@ -24,5 +23,3 @@ doldacond_shell_CPPFLAGS=@GTK2_CFLAGS@ @LIBNOTIFY_CFLAGS@ \
        basename="$${target%.gtk}"; \
        cpp $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $< \
         | $(top_srcdir)/common/makegdesc -h "$${basename}.gtkh" >$@
-
-appdir=$(datadir)/applications